Gerber

Aus TARGET 3001! PCB Design Freeware ist eine Layout CAD Software|Support, Tutorials, Shop

Gerber274d.png
Gerber274x.png
Siehe auch:

Einführung in Gerber (englisch)
Bohr Ausgabe
Gerber Spezial
Probleme beim Einlesen von X-Gerber




Inhaltsverzeichnis

Allgemeines

Wenn Sie das Layout eines Leiterplattenprojektes, bei einem industriellen Fertigungsbetrieb in Auftrag geben möchten, werden Sie nach Daten im Gerber Format gefragt. Dabei unterscheidet man Standardgerber (RS274D ) und sogenanntes Extended Gerber (RS274X), auch XGerber genannt. Der Unterschied zwischen den beiden besteht darin, dass Gerber RS174D eine extra Datei für die Blendeninformationen benötigt, diese jedoch bei XGerber entfällt.

Wenn Sie die gesamte Gerberproblematik umgehen wollen, übergeben Sie einfach Ihr TARGET 3001! Projekt im Format *.T3001 Ihrem Leiterplattenhersteller. Noch einfacher geht es mit dem in TARGET 3001! eingebauten Kalkulator und Bestellmechanismus bei PCB-Pool (R)

Die Erzeugung von Gerberdaten in TARGET 3001!

Öffnen Sie zunächst Ihr Projekt in TARGET 3001!. Im Folgenden wählen wir das Beispielprojekt PIC_3D.T3001. Wählen Sie nun im Menü Datei / Ein-/Ausgabe-Formate / Produktion / "(X-)Gerber und Bohr Ausgabe (PCBout...)" oder drücken Sie in der Layoutansicht einfach auf diese Ikone in der Werkzeugleiste: Gerberbutton.jpg

Es öffnet sich der folgende Dialog:


TARGET3001! cam Daten erzeugen


Gemäß der Ausgestaltung Ihres Projekts werden die erforderlichen Gerberdaten angezeigt (Haken vor der jew. Dateiart ist gesetzt).

Akzeptieren Sie den vorgeschlagenen Zielordner oder wählen Sie einen Zielordner, in dem die angezeigten XGerber-Daten abgespeichert werden sollen. Drücken Sie START. Die XGerber-Daten werden nun in Ihrem Zielverzeichnis erzeugt. Das ist schon alles.

Weitere Einstellungsmöglichkeiten haben Sie, wenn Sie den Spezial>> -Knopf drücken.

_____________________________________________________________
Wichtiger technischer Hibweis für Leiterplattenhersteller:

ab Version 17.4.0.23 werden die Kupfer-Layer bei der Gerberausgabe von oben herab gezählt:

doppelseitig:
L1 = Top
L2 = Bottom

oder

n-fach Multilayer:
L1 = Top
L2, L3, L4, L5... = Innenlagen von oben herab gezählt
Ln = Bottom

Bislang wurde von unten nach oben gezählt. Das ist in der PCB-Welt aber anscheinend ungebräuchlich und führte hin und wieder zu einer umgekehrten Reihenfolge bei den Innenlagen.

_____________________________________________________________




Das Beispielprojekt PIC.T3001! liefert folgende Gerberdaten:



Gerberpic.jpg


pic.Apr = TARGET 3001! Blendenliste
pic.Bot = 2 = Kupfer unten L2 ( *.Bot )
pic.Drill = Durchkontaktierte Bohrungen
pic.Info = Informationen für den Leiterplattenhersteller
pic.Outline = 23 = Platinen-Umriss ( *.Outline )
pic.PosiTop = 21 = Bestückungsdruck oben ( *.PosiTop )
pic.StopBot = 4 = Lötstoppmaske unten ( *.StopBot )
pic.StopTop = 18 = Lötstoppmaske oben ( *.StopTop )
pic.Tool = Bohrerliste, Werkzeugliste
pic.Top = 16 = Kupfer oben L1 ( *.Top )
pic.Whl = Eagle kompatible Blendenliste (whl steht für Blendenrad ="-wheel")


Der Inhalt des pic_3D.info files dient der Information für den Leiterplattenhersteller über das Projekt. Es hat in diesem Fall folgendes Aussehen:


GerberpicInfo.jpg


Übergeben Sie alle diese Dateien an Ihren Leiterplattenhersteller.

Das Besondere an diesem XGerber Ausgabetreiber ist, dass zwar XGerber-Daten erzeugt werden, diese aber dennoch von "alten" Gerber Maschinen verwertet werden können, da nur "alte" Gerber Befehle verwendet werden. Es werden beispielsweise Gerber-Blendendaten mitgeliefert, die für CAM Betriebe, die mit XGerber arbeiten können überflüssig sind, aber von Herstellerbetrieben, die mit Standard Gerber arbeiten, benötigt werden.

Mit dem Schaltknopf "Spezial" können sie zuvor weitere Spezifikationen vornehmen.

Das Einlesen von Gerberdaten nach TARGET 3001!

Ein Hinweis vorweg: TARGET 3001! ist kein Gerber-Viewer! Die Importfunktion dient hauptsächlich der Übernahme von Daten aus anderen CAD-Systemen. Wenn Sie Ihre Gerberdaten prüfen wollen, empfehlen wir den Gerber-Viewer GC-Prevue.

XGerber und Excellon einlesen

Sie können ein Layout, das Ihnen in XGerber- oder Excellon Daten vorliegt, Lage für Lage in TARGET 3001! einlesen, um somit Ihr XGerber-Layout darzustellen. Ein XGerber File ist eine Textdatei und hat beispielsweise folgendes Aussehen:

%FSLAX23Y23*%
%MOIN*%
%ADD10R,0.053X0.016*%
%ADD11R,0.030X0.030*%
%ADD12R,0.050X0.060*%
%ADD13R,0.049X0.047*%
%ADD14R,0.057X0.022*%
%ADD15C,0.010*%
%ADD16C,0.047*%
G36*
X4135Y3005D02*
X2575D01*
Y3445D01*
X2758D01*
X2759Y3440D01*
X2756Y3439D01*
X2749Y3433D01*
...

Ein Excellon File (für die Bohrungen) ist ebenfalls eine Textdatei und hat beispielsweise folgendes Aussehen:

M48
INCH,LZ
T1F00S00C0.028
T2F00S00C0.035
%
T01
X03325Y0311
X03031Y03115
X02773Y0311
Y03409
...
T02
X03031Y03414
X03325Y03409
...
M30


Wenn Sie Datenmaterial vorliegen haben, das eine gänzlich andere Struktur hat, ist dies ein Hinweis darauf, dass es sich nicht um XGerber oder Excellon handelt. Den Eröffnungsdialog zum XGerberimport finden Sie in TARGET 3001! unter: Menü Datei/Ein-/Ausgabe-Formate/Datenaustausch/Dokumentation/XGerber und Excellon einlesen. Der folgende Dialog öffnet sich:


X-Gerber und Excellon einlesen


Eine XGerberdatei wird im TARGET 3001!-Dialog in einer Zeile notiert und somit zum Konvertieren vorgemerkt. Betätigen Sie im Dialog also zunächst Knopf (1) um den Windows Browser zur Dateiauswahl zu öffnen. Geben Sie dann an, um welche Art Daten es sich handelt (2). Danach bestimmen Sie mit (3), auf welcher Ebene in TARGET 3001! die Daten landen sollen (2 Kupfer unten, 24 Bohrlöcher... ). Nun sehen Sie diese Datei bereits in der 1 Zeile des Dialogfensters gelistet (4):


X_Gerber und Excellon einlesen


Klicken Sie nun auf den Knopf: "Neue Zeile". Damit machen Sie TARGET 3001! bereit, eine neue Datei in einer neuen Zeile aufzunehmen. Eine Excellon-Datei übernehmen Sie genau so.


X-Gerber und Excellon einlesen


Wenn Sie im Feld rechts unter "Datenformat" den Knopf setzen:"Datei enthält Excellon", haben Sie die Möglichkeit mittels des "Excellon Faktors" die Darstellung der Bohrdaten zu beeinflussen. Wie groß der Faktor zu sein hat bestimmt sich danach, um ein Wievielfaches größer oder kleiner Ihre Bohrdaten dargestellt werden (ausprobieren!). Drücken Sie auf Start um Ihre ausgewählten Dateien zu konvertieren (einzulesen).

Wenn Ihre Excellon-Bohrdatei keine Informationen zu den Durchmessern der einzelnen Werkzeuge enthält, Sie aber die Durchmesser kennen, dann können Sie diese der Bohrdatei einfach mit einem Texteditor voranstellen:

M71
T1C0.6
T2C0.8
...
T17C3.2
G90
M72
T1
X00224Y03282
X00324Y03282
X00424Y03282
X00424Y03487
...

M71 stellt kurz auf mm um. Hinter dem T steht jeweils die Werkzeugnummer z.B. 1...17 und hinter dem C der Bohrerdurchmesser in mm. Dezimaltrenner ist der Punkt. Bei G90 begann die vorhandene Datei. M72 stellt übrigens wieder auf zöllig um, was auch die Standard-Einstellung bei Excellon ist.

Sonderfall: XGerber einlesen mit Massefläche (Löschungen)

Beispielsweise liegt Ihnen ein Layout vor, das Ihr XGerber-Viewer wie folgt ausgibt:


XGerberEinlesen1.jpg


Wenn Sie XGerber oben (Ebene 16) und die Bohrungen (Ebene 24) in TARGET 3001! eingelesen haben...



X-Gerber und Excellon einlesen


...sehen Sie folgendes Bild, das sich allerdings vom Bild Ihres XGerber-Viewers unterscheidet. Die Massefläche hat scheinbar Teile Ihres Ursprungslayouts überdeckt:


XGerberEinlesen2.jpg


Der Trick ist, dass Sie die XGerber-Informationen, die Sie auf zwei TARGET 3001!-Lagen eingelesen haben, nun auf mehrere Lagen verteilen müssen. Schalten Sie zuerst bitte im "Menü Fenster/Einstellungen / Optionen" den Punkt "Bauteil immer komplett" ein, oder drücken Sie im Zeiger-Werkzeug den unteren Knopf (roter Pfeil). Jetzt sehen Sie die eingelesene Leiterplatte vor sich und klicken möglichst weit in der rechten unteren Ecke auf die Massefläche. Sie sehen, es wird nicht alles markiert, was dunkelblau ist...


XGerberEinlesen4.jpg


Die gesamte zusammenhängende Massefläche, die aus Dreiecken zusammengesetzt ist, wird nun selektiert. Jetzt drücken Sie [ä] wie ändern und setzen alle selektierten "Dreiecke" auf Ebene "14 = Fläche oben" (die Ebene, die für eine Masseflächendefinition auf Kupfer oben vorgesehen ist). Wenn Sie die Dreiecke, von denen hier die Rede ist sehen wollen, drücken Sie die Raute-Taste [#]. Sie erreichen dadurch den Schnellzeichenmodus, der Ihnen eine Art Röntgenansicht Ihres Layouts bringt. Wieder zurück mit [#].


Dreiecke ändern


Im Ebenendialog schalten Sie nun die Ebene 14 unsichtbar. Dies bedeutet, Sie blenden diese Ebene aus (Sie löschen sie dadurch nicht). Was Sie sehen, ist der verbleibende Rest:


XGerberEinlesen6.jpg


Nun müssen Sie bestimmte Teile des verbliebenen Layouts als Löschung definieren und zwar alles, was nicht Kupfer ist. Diese Bereiche sind ebenfalls als gefüllte Dreiecke definiert. Fangen und selektieren Sie dazu die ganze Platine mit einem Fangfenster (M1H). Druck auf [ä] erlaubt die Auswahl gefüllter Dreiecke:


Ändern der markierten Elemente


Setzen Sie die nun selektierten Elemente auf Ebene "15=Lösch oben".


Dreiecke ändern



XGerberEinlesen9.jpg



Jetzt lassen Sie sich wieder alle Ebenen anzeigen. Fertig.


XGerberEinlesen10.jpg



Gerber und Excellon einlesen

Folgenden Dialog öffnen Sie durch Menü Datei / Ein-/Ausgabe-Formate / Datenaustausch/Dokumentation / "Gerber und Excellon einlesen".


GerberEinlesen.jpg



Allgemeines

Mit diesem Werkzeug können Sie ältere Gerber-Daten von Fremdsystemen einlesen und ggf. weiterverarbeiten. Der Gerber-Standard RS274D ist zum einen sehr umfangreich und zum anderen z.T. nicht gut definiert, so dass es zu Problemen und Ungenauigkeiten kommen kann. Zum Prüfen von Gerber-Daten benutzen Sie bitte GC-Prevue, das Sie sich kostenlos von unserer [[[Download]] laden können.

Gerber-Files einlesen

  • Öffnen Sie ein neues Projekt "Platine ohne Schaltplan"
  • Klicken Sie auf "Gerber & Excellon einlesen" im Menü "DATEI / Ein-/Ausgabeformate / Datenaustausch"
  • Wählen Sie Ihr Standard-Verzeichnis aus, in dem sich die zu bearbeitenden Gerberdateien befinden
  • Wählen Sie die entsprechende Blenden- und Bohrerliste aus.
  • Klicken Sie auf "Ebenen-Konfiguration laden", wenn Sie die vorhandenen Ebenenkonfigurationen im TARGET 3001!-Verzeichnis benutzen möchten, oder wenn Sie bereits eigene Konfigurationen angelegt haben. Hier haben Sie die Möglichkeit "Gerberkonfigurationen" (durch die Gerber-Ausgabe angelegte Einstellungen *.GC) oder "GerberIn-Konfigurationen" (durch hier angelegte Einstellungen *.GIC) zu öffnen
  • Jetzt erscheint der Dialog "Konfiguration laden". Hier können Sie evtl. einen neuen Namen für die Konfigurationsdateien eingeben.Die Konfigurationsdateien werden im ASCII-Format gespeichert. Alle von uns mitgelieferten Konfigurationsdateien haben Sternchen in den Dateinamen (.z.B. *.BOT für Kupfer unten). Tragen Sie in diesem Dialog also einen sinnvollen Dateinamen, der Ihrem Gerber-File entspricht, ein.
  • Können Sie keine vorhandene Konfiguration nutzen, so legen Sie bitte eine eigene neu an. Dazu teilen Sie TARGET 3001! mit, welche Lage (z.B. Kupfer unten) sich in welcher Datei befindet (z.B. TESTFILE.BOT)
  • Klicken Sie auf Neuer Eintrag, um weitere Ebenen anzugeben, z.B. Bohrdatei *.DRL.
  • Haben Sie alle Einstellungen abgeschlossen, dann betätigen Sie "START".

Achtung: Die Gerber-Daten der Lötstopebene sollten auf einer anderen Ebene als z.B. "LötstopUnten" eingelesen werden, denn TARGET 3001! berechnet automatisch die Pads der Lötstopebene durch Aktivierung im Ebenen-Dialog. Gerber-Daten der Lötstopebene mit Bedeckung der Durchkontaktierungen" werden dann nämlich ignoriert, bzw. von den "berechneten" wieder überdeckt.

Steht das von Ihnen benötigte fremde Blenden-Format für die Blendenliste in TARGET 3001! nicht zur Auswahl, schreiben Sie die Liste bitte mit einem Text-Editor in eine TARGET 3001!-Blendenliste um:

Fremde Blendenliste: Beispiel.APR

	Code	Size	Shape		Type
1	D10	60	square		flash
2	D11	60	round		flash
3	D12		not used	
4	D13		not used	
5	D14	40	round		flash
6	D15		not used
7	D16	80	round		flash
8	D17		not used	
9	D18		not used	
10	D19		not used	
11	D70		not used	
12	D71	50	round		flash
13	D20		not used
14	D21	86	round		flash
15	D22	100	round		flash 
16	D23		not used
17	D24		not used
18	D25	05	round		line
19	D26	10	round		line
20	D27	12	round		line
21	D28	25	round		line
22	D29	40	round		line
23	D72	50	round		line
24	D73	100	round		line


TARGET 3001!-Blendendatei Beispiel.BLN

D10 BR 60 60
D11 BE 60 60
D14 BE 40 40
D16 BE 80 80
D71 BE 50 50
D21 BE 86 86
D22 BE 100 100
D25 FK 5 5
D26 FK 10 10
D27 FK 12 12
D28 FK 25 25
D29 FK 40 40
D72 FK 50 50
D73 FK 100 100

Die Dateiendung ist *.BLN. Die Textzeilen werden mit [Return] abgeschlossen (=CR/LF). Das Format jeder einzelnen Textzeile ist:

D-Code Blendenart Breite Höhe

Die Elemente innerhalb jeder Zeile sind durch Leerzeichen (Space) getrennt. D-Code steht für "D10" bis "D999", nicht zwingend fortfolgend. TARGET 3001! kennt folgende Blendenarten:

FK: Fahr-Kreis: kreisförmige Fahrblende z.B. für Leiterbahnen (z.B. von Draw, Round)
FQ: Fahr-Quadrat: quadratische Fahrblende für Rechtecke (z.B. von Square)
BE: Blitz-Ellipse: ellipt./runde Blitzblende für Lötaugen (z.B. von  Round, Obround oder Oblong)
BA: Blitz-Achteck: achteckige Blitzblende für Lötaugen (z.B. von Octagon oder evtl. Oblong)
BR: Blitz-Rechteck: rechteckige Blitzblende für Lötaugen (z.B. von Rectangle oder Rect oder Square)
BO: Blitz-Oval: ovale Blitzblende für Lötaugen (z.B. von Oblong, Obround)
BP: Blitz-Passer: Passermarke
BB: Blitz-Bohrung: Symbol zur Darstellung eines Bohrlochs

Breite und Höhe werden in mil angegeben: 1 mm = 39,37 mil; 1 mil = 0,0254 mm. Für runde oder quadratische Blenden werden Breite und Höhe mit identischen Werten angegeben.

Mit dem TARGET 3001! XGerber Import alte Standard Gerbers (RS274D) einlesen

XGerber (RS274X) enthält die Blendeninformationen in der eigentlichen Layout Datei. Wenn Sie jedoch alte Standard Gerberdateien (RS274D) einlesen möchten, so müssen Sie die mitgelieferte Blendendatei finden und von TARGET interpretieren lassen. Leider sind Blendendateien in keiner Weise genormt. Weder die Endung des Dateinamens noch die Informationen, die in der Datei selbst stehen. Glücklicherweise sind wenigstens alle Dateien (Gerber-, Blenden, Bohr- und Bohrer-Dateien normale lesbare Text-Dateien). Öffnen Sie zunächst den Importdialog im Menü Datei/Ein-/Ausgabeformate/Datenaustausch/Dokumentation/XGerber und Excellon einlesen:


Gerber1.jpg


Es öffnet sich der Dialog des X-Gerberimports, in den nun Zeile für Zeile die einzelnen Bilder als Dateien in die einzelnen Ebenen eingelesen werden. Bestimmen Sie welche Datei sie zuerst einlesen möchten und auf welche Lage in TARGET 3001! diese gelangen soll. Um festzustellen, welche Datei welchen Inhalt hat, ist ein wenig Geschick und Herumprobieren gefordert. Manchmal existiert eine Info-Datei, die beschreibt, in welcher Datei was enthalten ist. Kupfer oben ist oft mit TOP oder T im Dateinamen angedeutet, Kufer unten oft mit BOT oder B.


Gerber2.jpg


Suchen Sie nach Ihren Gerberdaten in Ihrer Verzeichnisstruktur ("Datei einlesen", oben rechts). In diesem Beispiel wählen wir als Zielebene die Ebene 2, Kupfer unten.


Gerber3.jpg


Das Gleiche tun Sie mit der entsprechenden Datei...


Gerber4.jpg


..die die Daten für Kupfer oben erhält. Lesen sie sie auf Lage 16, Kupfer oben, ein.


Gerber5.jpg


Wenn Sie auf den "Start" Knopf drücken, werden Sie zunächst gefragt, ob Sie eine Blenden-Datei suchen wollen, da die sogenannten D-Codes noch nicht hinreichend definiert sind. Die D-Codes geben die Formen und Größen der Blenden an, die dann mit Hilfe der eigentlichen Gerber-Dateien vor einer Lichtquelle hin und her bewegt werden. Die Blendendatei ist also eine Art Beschreibung der Licht-Werkzeuge, die Gerberdatei sagt dann, was mit damit wo gemacht wird.


Gerber6.jpg


Drücken Sie den Knopf "Ja" und suchen Sie aus Ihrem Set der zu importierenden Gerberdaten die Blendendatei aus.


Gerber7.jpg


Blendendateien haben oft A oder APR (aperture = Blende) oder WHL (Wheel= Blenden-Teller/Rad) als Kennung im Dateinamen


Gerber8.jpg


Nachdem Sie eine geeignete Datei gefunden und ausgewählt haben, öffnet sich der Dialog zur Interpretation der Blendendaten. Eine Blendendatei besteht meist aus einem Header und ggf. aus einem Anhang, die beide gelöscht werden sollten. Interessant sind nur die Zeilen, die die D-Codes D10,D11,D12... enthalten.


Blendendatei suchen und auswerten


Wie eine Zeile der D-Codes aufgebaut ist, ist nicht bestimmt. Das Bild zeigt nur ein Beispiel. Man schaut sich eine Zeile der D-Codes an und muss nun die Abfolge der Parameter spaltenweise interpretieren. Der Knopf [Automatik] hilft Ihnen, eine Vorauswahl zu treffen. Im Beispiel bestimmt der erste Parameter den D-Code, der zweite Parameter die Blendenform (ROUND oder SQUARE, die TARGET 3001! als Rund bzw. Rechteck interpretiert), der dritte Parameter gibt Breite oder Durchmesser der Blende an. Da es in unserem Beispiel keine Höhenangabe als vierten Parameter gibt, stellen wir die Auswahlbox für die Höhe ebenfalls auf "3. Parameter" ein. In welcher Einheit Ihre Gerberdaten daher kommen, geben Sie im letzten Feld an. Wenn die Folge der Parameter stimmt, drücken Sie auf den Knopf "Blenden verwenden". Sehen Sie nun Ihre Kupfer oben und unten - Seiten im TARGET 3001! Layout.


Gerber10.jpg



Wie unterscheiden sich Gerber und G-Code?

G-Code und Gerber sind ähnlich aber sie beschreiben unterschiedliche Dinge: Gerber beschreibt das Zeichnen eines Layers (= eine Zeichenebene) einer Leiterplatte. Ein Befehl in Gerber hat zumeist ein Stück Leiterbahn oder ein Lötpad zum Gegenstand. G-Code wird zur Ansteuerung von Fräsautomaten verwendet, genauer, zur Bewegung eines Fräswerkzeuges. Beim Isolationsfräsen würden Leiterbahnen und Lötpads allerdings zerstört, wenn man ein Frästool in ihnen bewegt. Das, was stehen bleiben soll, würde weggefräst. Daher muss die Bewegung des Frästools außen um die Kupferelemente herum verlaufen, so dass Isolationskanäle entstehen. TARGET 3001! kann G-Code für PCB erzeugen, mit Rücksicht auf Werkzeugdurchmesser und Leiterbahnbreiten. Da TARGET in der Lage ist, Gerber files zu importieren, kann man es als einen universellen Gerber-to-G-Code Konverter verwenden.


G-Code kann in TARGET 3001! wie folgt erzeugt werden:


Gcode d 1.jpg



Dieser Menüeintrag öffnet den folgenden Dialog, der zwei Möglichkeiten der G-Code Auswahl ermöglicht.


Isolationsfräsen



Ansichten
+49(0)6659 919444
Mo-Do 8:00-16:30
Fr 8:00-14:30
(MEZ/MESZ)
Mitmachen: