Dokumentation

Eagle-Befehle und ihre Entsprechungen in TARGET 3001!

In diesem Überblick werden alle Eagle®* Befehle in alphabetischer Reihenfolge aufgelistet, kurz beschrieben und erklärt, wie die entsprechende Funktion in TARGET 3001! aufgerufen wird. Der Überblick soll dem erfahrenen Eagle®-Anwender dienen, der zu TARGET 3001! umsteigt oder der beide Systeme gleichzeitig einsetzen will. Wenn bei der Arbeit dennoch irgendwelche Fragen oder Probleme auftreten, rufen Sie uns bitte an (06659 / 919 444) oder senden Sie uns eine eMail target@ibfriedrich.com, bevor Sie lange herumprobieren und verzweifeln.


Die Erfahrung hat gezeigt, dass man nur widerwillig ein fremdes System erlernt, wenn man "seines" schon bestens beherrscht. Dennoch möchten wir Sie ermutigen, denn man kann verschiedene Systeme nur vergleichen, wenn man sie gleich gut kennt. Ihre vorhandenen Eagle®-Projekte können Sie nach TARGET 3001! konvertieren und auch umgekehrt. Auch Ihre Eagle®-Bibliotheken können problemlos nach TARGET 3001! konvertiert werden.


Weitere Artikel zum Thema Eagle®:
Eagle, Eagle-Projekt öffnen, Eagle Bibliothek als Skript importieren, Eagle Dateien als Skript importieren, Eagle-Export


* Eagle ist ein eingetragenes Warenzeichen der Fa. Autodesk.

ADD

Bauteil in eine Zeichnung einfügen.

In TARGET 3001!:

Drücken Sie einfach die Taste [Einfg] oder klicken Sie auf diese Ikone: InsertComponent.jpg Finden Sie dann das geeignete Bauteil im Bibliotheksbrowser und fügen Sie es an der gewünschten Stelle ein. Im Browser können Sie die Bauteile direkt sichtbar durchblättern. Zudem stehen verschiedene Methoden zum Suchen zur Verfügung. Interessant ist vor allem die Parametrische Suche, die Sie im Bauteilbrowser in der Spalte links bem gesuchten Bauteiltyp findet: Parametrische suche icon.jpg Sie können ggf. direkt Datenblätter und Preise zum gewünschten Bauteil abrufen. Ein Bauteil kann in TARGET, nachdem es als Symbol in den Schaltplan oder als Gehäuse in die Platine eingefügt wurde, noch beliebig bearbeitet werden. Es stellt kein Problem dar, z.B. beim eingefügten Bustreiber 74244 den Steuerkopf nachträglich nach unten zu verschieben, wenn die Schaltung so besser lesbar wird. Oder machen Sie schnell den Pin 1 eines ICs rechteckig oder verbiegen Sie ein Beinchen eines Transistors, damit noch eine Leiterbahn dazwischen hindurch passt...

ARC

Zeichnen von Kreisbögen.

In TARGET 3001!:

Klicken Sie auf diese Ikonen: Pen.jpg und Arc.jpg und zeichnen Sie einen "Torus". Ein späterer Doppelklick auf den Kreisbogen öffnet dessen "Ändern"- Dialog, in welchem Sie den Kreisbogen bearbeiten können.


ASSIGN

Belegen der Funktionstasten.

In TARGET 3001!:

Die Funktionstasten sind bereits mit den gebräuchlichsten Befehlen belegt und nicht anders programmierbar:


[F1] Hilfe

[F2] Biblioitheksbrowser

[F3] Umschaltung zwischen Schaltplan und Platine (Cross Probe)

[F4] Koordinaten-Einheit umschalten (mil, Zoll, mm, um)

[F5] Sichtbarkeit des Rasters umschalten (unsichtbar, Linien, Punkte)

[F6] Raster fängt umschalten (snap on grid)

[F7] Bild formatfüllend zoomen (win fit)

[F8] Fadenkreuz umschalten (unsichtbar, 90°, 90°+45°)

[F9] Simulator starten (Schaltplan) oder Autorouter starten (Platine)

[F10] ins Menü springen

[F11] Gerberausgabe starten

[F12] Luftlinien neu berechnen (Layout)


Sie können aber einige andere Knöpfe programmieren: Sets von sichtbaren Ebenen in der Ebenen-Werkzeugleiste oder Typen von Durchkontaktierungen in den Duko-Optionen oder Typen von Leiterbahnen in den Leiterbahn-Optionen.

AUTO

Autorouter aktivieren.

In TARGET 3001!:

Klicken Sie auf diese Ikonen: MagicWand.jpg und AutoRouter.jpg oder drücken Sie in der Platine [F9]. Folgen Sie den Instruktionen im Dialog. Der TARGET Autorouter arbeitet ohne Raster. Fehlermeldungen wie "Unreachable pad" kommen somit nicht vor und die Bahnen werden an den engsten Stellen verlegt, solange es denn überhaupt passt. Ein "Routing Grid" muss daher nicht eingestellt werden und die Geschwindigkeit des Routers sinkt auch nicht mit dem Quadrat der Rasterpunkte.


BOARD

Platinen (Board-) Datei erzeugen.

In TARGET 3001!:

Nicht erforderlich, wenn Sie eine "Platine mit Schaltplan" erzeugt haben. TARGET hält Schaltplan und Platine in einer Datei *.T3001. Schalten Sie zwischen Schaltplan und Platine direkt hin und her, benutzen Sie dazu diese Ikonen: GotoPCB.jpg und GotoSchematic.jpg. Wenn Sie ein Gehäuse im Layout markiert haben, drücken Sie einfach [F3], um das entsprechende Symbol im Schaltplan zu sehen und umgekehrt. Ebenso funktioniert das mit markierten Signalen (Cross-Probe).

Zum Platzieren der Gehäuse startet TARGET beim ersten Wechsel vom Schaltplan zur Platine den Autoplatzierer. Wenn Sie später im Schaltplan weitere Bauteile einfügen, können Sie im Layout den Autoplatzierer für die entsprechenden Gehäuse erneut manuell starten. Sie finden ihn im Menü "Aktionen". Oder schieben Sie die restlichen Gehäuse einfach von der Liste unten rechts in der Sidebar ins Layout. Auch mit der Taste [Einfg] können Sie die weiteren Gehäuse hereinholen.

BUS

Zeichnen von Bussen im Schaltplan.

In TARGET 3001!:

Bitte klicken Sie auf diese Ikonen:DrawSignal.jpg und Bus.jpg. In TARGET 3001! können Sie zwar verschiedene Busse durch die graphische Verlegung unterscheiden und Sie können diese auch entsprechend unterschiedlich beschriften, aber jeder Bus in TARGET 3001! beinhaltet immer alle (!) Signale. Zunächst ziehen Sie den Bus per Mausklick (Standard-Darstellung in blau). Wechseln Sie in den Modus "Signal verlegen". Klicken Sie auf den Bus und ein Dialog öffnet sich, der es Ihnen ermöglicht, alle bisherigen Signale des Schaltplans aus dem Bus herauszuführen. Ein Klappmenü gewährt Ihnen die Auswahl. Sie können auch an dieser Stelle den Bus-Assistenten aufrufen, der Ihnen umfassende Möglichkeiten eröffnet:

BusAssi.jpg


CHANGE

Ändern von Parametern.

In TARGET 3001!:

Gewünschtes Element mit einfachem Mausklick anwählen, dann Drücken der Taste [ä] wie "ändern". Es öffnet sich der entsprechende Eingabedialog. Oder Doppelklick auf ein beliebiges Element. Wenn sich mehrere Elemente am selben Fleck befinden, können Sie zunächst [w] drücken um ein Element anzuwählen. Mit [+] und [-] können Sie dann in der Nähe herumsuchen, bis das gewünschte Element blinkt. Dann drücken Sie [ä] zum Ändern.

CIRCLE

Kreis in eine Zeichnung einfügen.

In TARGET 3001!:

Klick auf die Ikonen Pen.jpg und CircleOpen.jpg oder CircleFilled.jpg


CLASS

Den Mindestabstand zwischen Signalen unterschiedlicher Netzklassen in Form einer Matrix angeben.


In TARGET 3001!:

Verwenden Sie die Zeiger Werkzeugleiste um Netze zu markieren. Verwenden Sie die Shift-Taste um Netze hinzu zu markieren. Doppelklick auf das Signal öffnet den "Signal ändern" Dialog. Hier Bestimmt man den Mindestabstand eines oder mehrere Signale zu den anderen Signalen.


CLOSE

Schließt ein Editor-Fenster.

In TARGET 3001!:

Schließen Sie einfach ein Dialogfenster, wie in WINDOWS üblich. Im TARGET können Sie von Ihrem Projekt mehrere Ansichten öffnen (Schaltplan-Seiten, Platinen-Ansichten). Ebenso können Sie in einem TARGET-Fenster sogar mehrere Projekte gleichzeitig öffnen, um z.B. Module über die Zwischenablage zu kopieren.


CONNECT

Zuornung von Pins und Pads in der Bibliothek.

In TARGET 3001!: In jedem Schaltplan-Symbol ist ein Verweis auf ein passendes Gehäuse vorhanden (Gehäusevorschlag). Eine Zuordnung von Pin und Pad findet in TARGET immer automatisch statt, wenn die Anschlussnummer identisch ist. Sie können im Schaltplan natürlich auch zusätzlich Anschlussnamen und im Layout Padnamen vergeben. Vom angegebenen Gehäusevorschlag dürfen Sie auch abweichen, z. B. in der Platine einen SMD14 statt des vorgeschlagenen DIL14 verwenden. Wenn im Gehäuse Verbindungen zwischen Pins bestehen oder wenn das selbe Signal an ein Gehäuse mehrfach angeschlossen werden muss, wird das in Eagle durch die Eigenschaften "all" und "any" ausgedrückt. In TARGET werden hierfür interne Verbindungen verwendet.

COPY

Kopieren von Objekten, Kopieren von Gruppen

In TARGET 3001!:

Markieren Sie die gewünschten Schaltungsteile und drücken Sie die Ikone Copy.jpg oder [Strg] + [Einfg]. Wenn Sie eine Gruppe markieren wollen, bedienen Sie sich des Tools Module.

TARGET 3001! kopiert die Daten in die Zwischenablage nicht nur um sie in andere TARGET Projekte zu übertragen, sondern die Bilder werden auch in einem Vektor-Graphik-Format nach MS-Word, OpenOffice und Corel-Draw kopierbar (WMF), ideal also für Dokumentationszwecke! Die Bilder sind dann immer noch verlustfrei skalierbar, ohne pixelig zu werden.

Auch können mit der Zwischenablage in Schaltplan und Layout mehrfach auftretende gleiche Kanäle vervielfältigt werden. Zeichnen Sie den Kanal zunächst einmal im Schaltplan und einmal im Layout. Kopieren Sie die Kanäle zunächst im Schaltplan und dann zeitnah die selben Teile im Layout. Der 7. Kanal im Layout weiß dann, dass er zum 7. Kanal im Schaltplan gehört. Dabei gilt: Signale, die beim Kopieren komplett markiert sind, werden als lokale, interne Signale gesehen und bekommen einen neuen künstlichen Namen (z.B. Sig$99). Signale, die nicht komplett gefangen wurden, also von denen wenigstens ein Segment unmarkiert blieb, werden als globale, externe Signale gesehen und behalten in den Kopien ihre Namen (z.B. GND).


Wenn Sie Elemente gruppieren wollen, so können Sie sie dies mit M2 tun.

GruppierenM2.png


Das Kopieren einer Gruppe erfolgt nach deren gesamthafter Markierung in gewohnter Windows-Manier

CUT

Gruppe in den Paste -Puffer laden.

In TARGET 3001!:

Ausschneiden für die Zwischenablage. Gewünschte Teile der Schaltung markieren und Ikone Cut.jpg drücken oder [Shift] + [Entf]. Um Elemente jedoch einfach nur auf eine andere Seite oder Ebene zu bringen, benutzen Sie die Taste [ä] und ändern die Seite/Ebene.


DELETE

Löschen von Objekten und Elementen.

In TARGET 3001!:

Nach dem Markieren drücken Sie die Taste [Entf]. TARGET hat eine dreistufige Lösch-Funktion: Sind autogeroutete Bahnen mit markiert, werden beim ersten Drücken von [Entf] nur diese gelöscht. Beim zweiten Druck von [Entf] werden auch die manuell verlegten Bahnen entfernt. Endlich beim dritten Drücken von [Entf] werden auch die Bauteile gelöscht. Haben Sie [Entf] einmal zu oft gedrückt, können Sie die Funktion "Rückgängig / Undo" im Menü "Aktionen" wählen.


DIR

Anzeigen von Inhaltsverzeichnissen.

In TARGET 3001!:

Bei allen Aktionen mit Dateien werden in TARGET Windows-kompatible Datei-Auswahl-Dialoge oder -Elemente verwendet.


DISPLAY

Auswählen der sichtbaren Layer.

In TARGET 3001!:

Drücken Sie Layers.jpg um diesen Dialog zu bekommen:

EbenenDlg.jpg


...oder schauen Sie in die Sidebar rechts, um diesen Dialog zu bekommen:

EbenenToolBar.jpg



Setzen oder Wegnehmen der Häkchen bei dem jeweiligen Layer schaltet die Sichtbarkeit um. Die Knöpfe ganz rechts können mit Sets von sichtbaren Ebenen programmiert werden, um schnell zwischen verschiedenen Platinen-Ansichten umschalten zu können.

Nachdem man ein Bearbeitungswerkzeug (z.B. "Leiterbahn verlegen") gewählt hat, klickt man mit der rechten Maustaste auf eine Ebenenziffer um diese Ebene zur aktiven Zeichenebene zu machen.

DRC

Design Rule Check (Platine prüfen).

In TARGET 3001!:

klicken Sie auf MagicWand.jpg und Check.jpg. Diese Funktion prüft Ihr Projekt (ggf. Schaltplan und Platine) gegen die im Dialog einzustellenden Parameter.


EDIT

Lade-Befehl

In TARGET 3001!:

Projekt Öffnen. Fertig. In TARGET können mehrere Fenster pro Projekt und sogar mehrere Projekte gleichzeitig angezeigt werden. TARGET unterscheidet nicht zwischen Schaltplan- und Layout-Datei sondern alle Informationen (*.SCH + *.BRD) landen in einem Projekt-File *.T3001. In diesem File werden sogar alle Informationen für die Simulation und die EMV-Analyse gespeichert.


ERC

Electrical Rule Check (Schaltplan prüfen).

In TARGET 3001!:

klicken Sie auf MagicWand.jpg und Check.jpg. Diese Funktion prüft Ihr Projekt (ggf. Schaltplan und Platine) gegen die im Dialog einzustellenden Parameter.



ERRORS

Zeigt Fehler, die vom DRC gefunden wurden.

In TARGET 3001!:

Alle gefundenen Fehler werden unmittelbar nach Beendigung des Checks in einer Liste angezeigt. Im Layout finden Sie an den Stellen, die der DRC anmeckert, ein Kästchen mit einem Kreuz. Ein Doppelklick auf dieses Kreuzchen öffnet einen Dialog, der den Fehler erklärt.


EXPORT

ASCII Dateien erzeugen.

In TARGET 3001!:

Verwenden Sie bitte im Menü "Datei / Ein- / Ausgabeformate" die Schnittstelle: "ASCII I/O-Schnittstelle". um das komplette File im Textformat zu exportieren.


GATESWAP

Äquivalente Gates vertauschen.

In TARGET 3001!:

Benutzen Sie diese Ikone MagicWand.jpg und dort diese Ikone GateSwap.jpg zum Tausch identischer Gatter. Es ist sogar ein Tausch über die Bauteilgrenze hinweg möglich. Zwei Gatter dürfen nur getauscht werden, wenn sie identisch sind und ihre Tauschnummern gleich und größer als Null sind.



GRID

Rasterdarstellung und -einheit einstellen.

In TARGET 3001!:

Klicken Sie bitte auf diesen Knopf View.jpg und dann auf diesen: Grid.jpg Hier lassen sich alle rasterbezogenen Einstellungen vornehmen.


GROUP

Selektieren mehrerer Bauteile und Elemente gleichzeitig.

In TARGET 3001!:

Selektieren Sie Objekte mit einfachem Mausklick, wählen Sie weitere hinzu durch gleichzeitiges Halten der Taste [Shift]. Oder ziehen Sie ein rechteckiges "Fangfenster" mit gehaltener linker Maustaste über den Bereich, den Sie markieren wollen. Auch das Fangfenster kann zusammen mit [Shift] eingesetzt werden, um weitere Bereiche hinzuzuwählen. Benutzen Sie auch den Selektionsassistenten im Menü "Bearbeiten" um beispielsweise alle Lötpads mit Bohrloch-Grösse 0,6mm zu markieren, um sie auf 0,8 mm zu erweitern.


Wenn Sie Elemete gruppieren wollen, so können Sie sie dies mit M2 tun.


GruppierenM2.png


Das Kopieren einer Gruppe erfolgt nach deren gesamthafter Markierung in gewohnter Windows-Manier.

HELP

Hilfe für den aktuellen Befehl anzeigen.

In TARGET 3001!:

Drücken Sie die Taste [F1] um die interaktive Hilfe zu starten. Je nachdem welche Aktion Sie gerade durchführen wollen, [F1] eröffnet den geeigneten Wiki-Artikel.

HOLE

Bohrloch in Platine oder Package einfügen.

In TARGET 3001!:

Bohrlöcher, falls erforderlich, werden immer in Einheit mit einem Pad definiert. Doppelklick auf das jeweilige Pad eröffnet den Dialog zum Editieren. Eine reine Befestigungsbohrung definieren Sie durch ein Pad, dessen Kupfer Sie kleiner einstellen als die Bohrung. Ebenso müssen Sie die Anschlussnummer auf Null setzen.


INFO

Eigenschaften von Objekten anzeigen.

In TARGET 3001!:

Doppelklick auf das Objekt öffnet den Dialog, der die wesentlichen einstellbaren Größen anzeigt. Lässt sich ein Objekt nicht anklicken, weil mehrere Objekte übereinander liegen, so fahren Sie den Mauszeiger über das Objekt und drücken so lange die Taste [w] für wählen, bis das gewünschte Objekt blinkt. Drücken Sie nun die Taste [ä] für ändern, um den selben Dialog zu öffnen. In vielen Dialogen gibt es noch zusätzliche "Eigenschaften"- Buttons, die Zusatzinformationen bieten und weitere Einstellungen zulassen.

INVOKE

Bestimmte Gates von Bauteilen holen.

In TARGET 3001!:

Sie können bei TARGET ein spezielles Gatter eines Bauteils in den Schaltplan holen, wenn Sie den Menüpunkt "Bauteile / Reste von Bauteilen importieren" benutzen. Jedes Gatter hat eine Eigenschaft "Einfügen als nächstes" oder "Einfügen als Rest". Normale Gatter werden meist "als nächstes" importiert, die Versorgungs-Symbole meist "als Rest". Normalerweise will man sich ja zunächst erstmal mit der Logik der Schaltung beschäftigen und erst später mit der Versorgung. Versorgungssysmbole müssen in TARGET immer (!) in den Schaltplan geholt und angeschlossen werden. Ein heimliches Anschließen des GND-Pins an das gleichnamige Signal gibt es nicht. Auch die Information, welche Pins an + und - angeschlossen werden, gehört in den Schaltplan.

JUNCTION

Markierungspunkt für zusammengehörige Netze setzen.

In TARGET 3001!:

Knoten im Schaltplan setzt TARGET normalerweise selbst. Das geschieht automatisch, wenn an einer Stelle mehr als zwei Bahn-Enden aufeinander treffen. Drücken Sie die Taste [.] um einen Knoten im Schaltplan manuell zu setzen. Es entsteht ein kleiner gefüllter Kreis, der breiter ist als die Signallinie. Wenn TARGET einen Knoten zuviel gesetzt hat, löschen Sie ihn einfach.


LABEL

Busse und Netze beschriften.

In TARGET 3001!:

Um Signale im Schaltplan zu beschriften, drücken Sie die Taste [n], wenn der Cursor auf einem Signalsegment steht. Wenn nun das Signal umbenannt wird, ändert sich auch diese Beschriftung. Da verschiedene Busse in TARGET nicht logisch unterschieden werden, können Sie diese ganz normal mit der Textfunktion ["] beschriften.


LAYER

Wechseln und definieren von Layern.

In TARGET 3001!: Layer gibt es in TARGET nur in der Layoutansicht. Verwenden Sie das Layer-Tool Layers.jpg um Ebenen zu definieren. Zum Sichtbarschalten können Sie auch die Ebenen-Werkzeugleiste in der Sidebar (Menü "Ansicht/Toolbars/Sidebarsichtbar") verwenden:

EbenenToolBar.jpg

MARK

Marke in der Zeichenfläche definieren.

In TARGET 3001!:

Stellen Sie einen relativen Nullpunkt ein, indem sie die Taste [Pos 1] bzw. (Home) drücken. In der Statuszeile links am unteren Bildrand hat sich die Koordinateneigenschaft von "ABS" =absolut auf "REL" =relativ geändert. Der relative Nullpunkt findet sich dort, wo der Cursor stand. Doppeltes Drücken dieser Taste an der selben Stelle holt die absolute Anzeige zurück. Zum Messen drücken Sie die Taste [m] um eine gerade Linie von einen Messpunkt zum anderen zu ziehen. Eine Bemaßung fügen Sie ein, indem Sie den Cursor an den Startpunkt fahren, die Taste [m] drücken, zum Endpunkt fahren und nochmals [m] drücken. Beim Markieren der Bemaßung gilt die Stellung des Schalters SelByElem.jpg. Ist dieser niedergedrückt, wird die entstandene Bemaßung immer komplett markiert.

MENU

Menüleiste verändern.

In TARGET 3001!:

TARGET arbeitet mit einer dynamischen Menüleiste. Je nach Schaltplan- oder Platinen-Ansicht wird die Menüleiste und die Werkzeugleiste automatisch umgebaut.


MIRROR

Objekte spiegeln.

In TARGET 3001!:

Markieren Sie die gewünschten Elemente. Die Cursorposition wird zur vertikalen Spiegelachse, wenn sie jetzt die Taste [s] für spiegeln drücken. Soll die Cursorposition die horizontale Spiegelachse sein, nehmen Sie bitte die Taste [Shift] + [S]. Beachten Sie: Ein (SMD-) Bauteil klappen Sie durch Spiegeln von der Unterseite der Platine nach oben und umgekehrt.


MOVE

Bewegen von Objekten und Elementen.

In TARGET 3001!:

Markieren Sie das oder die Elemente, die Sie bewegen möchten. (s.a. GROUP). Drücken Sie ggf. in der Auswahl DoubleArrow.jpg auf den Knopf SelByElem.jpg, um zu erreichen, dass bei Klick auf ein beliebiges Element eines Bauteils entweder das einzelne Elemente oder sofort das ganze Bauteil markiert wird. Klicken Sie nun mit gehaltener Maustaste auf das oder die markierten Objekte und verschieben Sie diese. Eine Phantomzeichnung bleibt am Cursor sichtbar, alle Signalleitungen werden erhalten und wie Gummibänder mitgezogen. Setzen Sie das Objekt an der gewünschten Stelle ab.

NAME

Anzeigen und Ändern von Namen.

In TARGET 3001!:

Klicken Sie doppelt auf ein Bauteil, das einen Namen trägt und editieren Sie ihn direkt in der sich öffnenden Dialogbox. Klicken Sie auch direkt einen Namen doppelt, um ihn zu verändern. Lösen Sie gegebenenfalls den Schaltknopf SelByElem.jpg unter dem Schaltknopf DoubleArrow.jpg um die Schrift separat markieren zu können. Namen können beliebig viele Zeichen enthalten.

NET

Zeichnen von Netzen im Schaltplan.

In TARGET 3001!:

Wählen Sie die Schaltfläche DrawSignal.jpg, um im Schaltplan Signalverbindungen zwischen Anschlusspins herzustellen. In der Statuszeile können Sie während des Verlegens den verwendeten Signalnamen sehen. Ein Doppelklick auf das Signal oder Einfachklick (markieren) und Taste [ä] öffnen den entsprechenden Dialog um Signaleigenschaften einzustellen, z.B. auch die Leiterbahnbreite u. ä. fur das spätere Autorouten mit dem Knopf [Eigenschaften].


OPEN

Öffnen einer Bibliothek.

In TARGET 3001!:

Entweder Sie drücken die Funktionstaste [F2] oder die Ikone Db.jpg um den Bibliotheksbrowser zu öffnen oder die Taste [Einfg], um ein Bauteil in die Schaltung zu holen. Um den Standard-Pfad für die Bibliotheken einzustellen, können Sie das Menü "Fenster / Einstellungen" benutzen.

OPTIMIZE

Zusammenfassen von Wire-Segmenten, die auf einer Linie liegen.

In TARGET 3001!:

TARGET fasst Leiterbahnsegmente in der Reorganisation automatisch zusammen (s. Menü "Datei"). Wenn Sie dies manuell bewerkstelligen möchten, ziehen Sie mit der Taste [z] den "falschen" Knick auf das Ende einer seiner Schenkel. Somit bekommt ein Segment die Länge Null und wird sofort gelöscht. Sichtbar können Sie die zusätzlichen Knicke machen, indem Sie die Röntgen-Ansicht verwenden (Taste [#]) und sich genügend weit hereinzoomen.

PACKAGE

Zuweisung eines Package für ein Device.

In TARGET 3001!:

Es gibt zwei verschiedene Arten von Bibliotheken in TARGET: Symbole-Bibliotheken mit zugehörigen Gehäuse-Vorschlägen und Gehäuse-Bibliotheken. Die Zuordnung geschieht normalerweise, indem man beim Erzeugen eines Symbol-Bauteils einen Gehäusevorschlag mit angibt. Von dem Gehäusevorschlag kann man sich später jedoch jederzeit lösen, indem man beim Bestücken statt des vorgeschlagenen Gehäuses ein anderes auswählt (z.B. SMD14 statt DIL14).

PAD

Platzieren von Pads in Packages.

In TARGET 3001!:

Pads werden in der Layout-Ansicht beim Zeichnen von Gehäusen benötigt. Drücken Sie in der Layout-Ansicht einfach die Taste [1]. Ein Pad hängt am Cursor. Drücken Sie jetzt die Taste [o], so können Sie die Optionen der zukünftigen Pads einstellen. Mit Mausklicks oder Taste [1] können Sie nun Pads absetzen. Zum genauen Platzieren können Sie statt der Maus auch die Cursor-Tasten verwenden. Ein Doppelklick auf das Pad öffnet den Dialog zum Editieren der Padeigenschaften:

Padaenddlg1.jpg

PASTE

Inhalt des Paste Puffers einfügen.

In TARGET 3001!:

Einfügen aus der Zwischenablage. Paste.jpg drücken oder [Shift] + [Einfg].

Um Elemente jedoch einfach nur auf eine andere Seite oder Ebene zu bringen, benutzen Sie die Taste [ä] und ändern die Seite/Ebene. Auch können mit der Zwischenablage in Schaltplan und Layout mehrfach auftretende gleiche Kanäle vervielfältigt werden. Zeichnen Sie den Kanal zunächst einmal im Schaltplan und einmal im Layout. Kopieren Sie die Kanäle zunächst im Schaltplan und dann zeitnah die selben Teile im Layout. Der 7. Kanal im Layout weiß dann, dass er zum 7. Kanal im Schaltplan gehört. Dabei gilt: Signale, die beim Kopieren komplett markiert sind, werden als lokale, interne Signale gesehen und bekommen einen neuen künstlichen Namen (z.B. Sig$99). Signale, die nicht komplett gefangen wurden, also von denen wenigstens ein Segment unmarkiert blieb, werden als globale, externe Signale gesehen und behalten in den Kopien ihren Namen (z.B. GND).

PIN

Anschlusspunkte in Symbolen definieren.

In TARGET 3001!:

Pins werden im Schaltplan zum Zeichnen von Anschlüssen in Symbolen benötigt. Drücken Sie in der Schaltplan-Ansicht einfach die Taste [1]. Ein Pin hängt am Cursor. Drücken Sie jetzt die Taste [o], so können Sie die Optionen der zukünftigen Pins einstellen. Mit Mausklicks oder Taste [1] können Sie nun Pins absetzen. Zum genauen Platzieren können Sie statt der Maus auch die Cursor-Tasten verwenden. Ein Doppelklick auf den Pin öffnet den Dialog zum Editieren der Pineigenschaften:

AnschlussDlg.jpg

PINSWAP

Äquivalente Pins/Pads vertauschen, die einen identischen Swaplevel ungleich Null haben.

In TARGET 3001!:

Gleichermaßen durch Betätigen der Taste PinSwap.jpg unter der Ikone MagicWand.jpg und anschließendes Klicken auf die beiden Pins. Diese müssen sich im selben Symbol befinden und die gleiche Tausch-Nummer haben, die aber nicht Null sein darf.


POLYGON

Zeichnen von Polygon-Flächen.

In TARGET 3001!:

KLicken Sie den Button Pen.jpg und dann den Button PolyFilled.jpg. Bestimmen Sie durch Mausklick die Schenkel des Polygons. Markieren Sie das geschlossene Polygon als ganzes und weisen Sie ihm ein Signal oder einen Layer zu, indem Sie nach markieren die Taste [ä] wie ändern drücken. In TARGET besteht das Polygon aus mehreren zusammenhängenden Dreiecken. Beim Markieren gilt die Stellung des Schalters SelByElem.jpg. Ist dieser niedergedrückt, wird das Polygon immer komplett markiert.

PREFIX

Präfix für Schaltzeichen festlegen.

In TARGET 3001!:

Das Präfix für den Bauteilnamen wird beim Exportieren des Symbols im Dialog ausgewählt bzw. eingegeben.


QUIT

Beendet die Arbeit mit EAGLE.

In TARGET 3001!:

Fenster schließen, wie in Windows.


RATSNEST

Neuberechnen der Luftlinien und Polygone.

In TARGET 3001!:

In der Layoutansicht im Menü "Aktionen / Luftlinien neu berechnen" auswählen oder einfach [Strg]+[L] drücken. Die Luftlinien sind in TARGET dynamisch. Nach jeder Änderung werden sie neu ausgerechnet. Wenn Sie ein Bauteil von rechts unten nach links oben bewegen, werden alle anderen Luftlinien ausgeblendet, nur die des bewegten Bauteils bleiben, damit Sie nicht vor lauter Bäumen den Wald nicht sehen. Bei der kleinsten Bewegung mit der Maus werden die Luftlinien neu berechnet und angezeigt. Dann sucht TARGET ob nicht links oben nähere Lötpunkte der Signale zu finden sind. Dieses dynamische Ratsnest ergibt eine sehr ehrliche Platzierungshilfe!

RECT

Rechteck in eine Zeichnung einfügen.

In TARGET 3001!:

In der Zeichnen-Funktion Pen.jpg den Unterpunkt RectangleFilled.jpg oder RectangleOpen.jpg wählen, je nachdem, ob das Rechteck gefüllt oder ungefüllt sein soll. Mit [o] können Sie die Optionen der zukünftigen Rechtecke festlegen. Mit einem Doppelklick oder der Taste [ä] können Sie vorhandene ändern.

REDO

Befehl erneut ausführen.

In TARGET 3001!:

Betätigen Sie Redo.jpg, 50 Schritte sind möglich.


REMOVE

Löschen von Dateien, Devices, Symbolen, Packages und Sheets.

In TARGET 3001!:

Dateien löschen Sie im Windows-Explorer. In TARGET selbst können Sie ansonsten alles Markierte mit der Taste [Entf] löschen. Eine TARGET Schaltung hat immer 100 Seiten, die sich nicht löschen lassen. Die Namen der Seiten können Sie im Hierarchie-Browser links am Bildrand einstellen.


RENAME

Symbole, devices oder Packages in einer Bibliothek umbenennen.

In TARGET 3001!:

Klicken Sie den betreffenden Text doppelt und geben Sie den neuen Namen ein.


REPLACE

Element in Platine austauschen.

In TARGET 3001!:

Löschen Sie das entsprechende Teil und setzen Sie ein neues ein. Benötigen Sie z.B. ein SMD14 statt des vorhandenen DIL14, dann verfahren Sie genau so. Wollen Sie jedoch mehrfach Teile ersetzen, dann benutzen Sie


im Schaltplaneditor: Menü "Bauteil", "Bauteilform austauschen und ersetzen",

im Layouteditor: Menü "Gehäuse", "Gehäuseform ersetzen oder updaten".

RIPUP

Verdrahtete in unverdrahtete Signale verwandeln.

In TARGET 3001!:

Im Layout: Leiterbahn komplett oder mehrere Segmente davon selektieren und [Entf] drücken. Oder gesamtes Signal mit dem Fernglas Search.jpg suchen und [Entf] drücken. Die Luftlinie ist sofort sichtbar. Wenn Ihnen das Ergebnis des Autorouters nicht gefällt, markieren Sie das gesamte Layout mit einem Fangfenster (im Zeigermodus mit gehaltener linker Maustaste ein Rechteck über dem gesamten Layout aufziehen). TARGET hat eine dreistufige Lösch-Funktion: Sind autogeroutete Bahnen mit markiert, werden beim ersten Drücken von [Entf] nur diese gelöscht. Beim zweiten Druck von [Entf] werden auch die manuell verlegten Bahnen entfernt. Endlich beim dritten Drücken von [Entf] werden auch die Bauteile gelöscht. Haben Sie [Entf] einmal zu oft gedrückt, können Sie die Funktion "Rückgängig / Undo" im Menü "Aktionen" wählen.


ROTATE

Drehen von Objekten und Elementen.

In TARGET 3001!:

Objekt markieren und [d] drücken. Drücken Sie auch [Shift]+[d] für das Einstellen beliebiger Drehwinkel. Drehzentrum ist dabei die Position des Mauszeigers!

ROUTE

Unverdrahtete Signale in verdrahtete Signale verwandeln.

In TARGET 3001!:

Die Funktionstaste F9 öffnet den Autorouter. Im Eröffnungsdialog können Sie sich das gewünschte Signal (die gewünschten Signale) aussuchen.

RUN

User-Language-Programme ausführen.

In TARGET 3001!:

Es gibt keine Batch-Script-Sprache. Alle wichtigen Funktionen sind in TARGET bereits direkt enthalten (Bauteil suchen, Stückliste, DXF etc...). Wenn Sie Ihre Projekt-Daten per Programm beeinflussen möchten, steht Ihnen die dokumentierte offene ASCII-Schnittstelle zur Verfügung. Diese Daten lassen sich beliebig mit Ihrer Lieblings-Programmiersprache bearbeiten, umformen und wenn Sie möchten, auch wieder einlesen.

SCRIPT

Befehls-Datei ausführen.

In TARGET 3001!:

Wenn Sie Ihre Projekt-Daten per Programm beeinflussen möchten, steht Ihnen die dokumentierte offene ASCII-Schnittstelle zur Verfügung. Deren Daten lassen sich beliebig mit Ihrer Lieblings-Programmiersprache bearbeiten, umformen und wenn Sie möchten, auch wieder als Projekt einlesen.

SET

Systemparameter verändern.

In TARGET 3001!:

Im Menü "Fenster / Einstellungen" können viele Eigenschaften gesetzt werden. Im Hierarchiebrowser (am linken Bildrand) stellen Sie Parameter in den Projekteigenschaften (rechter Mausklick) ein. Ansonsten stellt man alle Parameter in den entsprechenden Dialogen ein.


SHOW

Anzeigen von Namen, Elementen und Objekten.

In TARGET 3001!:

Signal oder Bauteil mit Hilfe des Fernglases Search.jpg suchen, und mit [F3] die Entsprechung im Schaltplan oder Layout anzeigen lassen (cross probe). Das markierte Element wird vergrößert zentral auf dem Bildschirm dargestellt.


SIGNAL

Signale definieren.

In TARGET 3001!:

Nachdem man Symbole aus den Bauteilbibliotheken in den Schaltplan hereingeholt hat, verbindet man sie mit der Funktion DrawSignal.jpg. Ein akustisches Signal bestätigt die Verbindung. Doppelklick auf das verlegte Signal öffnet den Editierdialog. Mit der Taste [o] können Sie die Optionen für zukünftige Signalsegmente festlegen.


SMASH

Loslösen von Name- und Value-Texten.

In TARGET 3001!:

Im erweiterten Zeigermodus DoubleArrow.jpg lösen Sie zunächst den Schaltknopf SelByElem.jpg. Nun haben Sie die Möglichkeit jedes einzelne Element, also auch die Texte, separat zu wählen und mit Doppelklick oder [ä] wie ändern zu editieren.

SMD

Platzieren von SMD-Pads in Packages.

In TARGET 3001!:

In TARGET gibt es keinen speziellen Unterschied zwischen Pads und SMDs. SMDs sind einfach Pads mit Ebene=16 oder 2 statt 100 und Bohrloch=0 statt einem anderen Wert. Sie können sogar direkt Padstacks zuweisen und somit z.B. Pads mit Blindbohrung erzeugen. Zunächst drücken Sie Pen.jpg und PlacePad.jpg oder Sie tippen die Taste [1]. Mit [o] können Sie die Optionen der zukünfigen Pads/SMDs festlegen. Dann platzieren Sie die SMDs mit normalen Mausklicks bzw. mit weiterem Drücken der Taste [1]. Definieren Sie Ebene=16="Kupfer oben". Wenn Sie später ein SMD- Bauteil auf Ebene 2="Kupfer unten" haben wollen, spiegeln Sie es einfach.


SPLIT

Knicke in Wires einfügen.

In TARGET 3001!:

Cursor auf gewünschte Knickposition fahren und Taste [z], wie ziehen drücken. Stellen Sie zuvor den Knickmodus im erweiterten Zeiger-Tool ein:

Pointer.jpg
bzw.
PointerToolBar.jpg
(gelb).

Somit können Sie einen neuen Knick erzeugen oder einen Bogen oder eine Spline-Kurve aus der Linie ziehen. Wenn Sie einen Knick wieder los werden wollen, ziehen Sie ebenfalls mit [z] auf dem Knick einen Schenkel zu Null. Um überflüssige Knicke zu entfernen, benutzen Sie die Reorganisation. Die Knicke erkennen Sie, wenn Sie mit Taste [#] die Röntgen-Ansicht einschalten.


STOP

Praktisch alle Aktionen werden mit der Taste [ESC] abgebrochen. Drücken Sie ggf. so lange [ESC], bis unten in der Statuszeile "Zeiger-Modus" steht. Wer lieber mit der Maus arbeitet, der kann mit einem Klick M12 die Taste [ESC] ersetzen.

TEXT

Platzieren Von Text.

In TARGET 3001!:

Drücken Sie die Taste [ß] (EsZett) oder die Taste ["] (Redezeichen) an der Stelle, wo der Text erscheinen soll. Im Layout sollten Sie momentan nur die Schriftart "TARGET" verwenden, da die Gerber-Ausgabe immer diese Schrift verwendet.


UNDO

Vorhergehenden Befehl zurücknehmen.

In TARGET 3001!:

Drücken Sie Taste Undo.jpg, 50 Schritte sind möglich.


USE

Bibliotheken vor dem Platzieren von Elementen Laden.

In TARGET 3001!:

Nicht nötig in TARGET. Stellen Sie allenfalls das Verzeichnis für Bibliotheken im Dialog "Fenster / Einstellungen" ein. Öffnen Sie mit Taste [Einfg] den Bibliotheksbrowser. Sie haben nun mehrere Möglichkeiten ein Bauteil zu finden. Benutzen Sie einfach die umfangreichen Suchfunktionen oder die Baum-Ansicht. Das einzufügende Bauteil kann dabei aus einer beliebigen Bibliothek stammen.

VALUE

Elementwert eintragen und ändern.

In TARGET 3001!:

Doppelklick auf das Griffkreuz des Symbols/Gehäuses eröffnet den entsprechenden Dialog, in dem der Elementwert eingegeben werden kann. Die Änderung findet natürlich gleichzeitig in Schaltplan und Platine statt. Bei einem Symbol z.B.

SymbolDlg.jpg

VIA

Platzieren von Durchkontaktierungen.

In TARGET 3001!:

Beim Leiterbahnverlegen drücken Sie einfach die Taste [.]. TARGET setzt eine Duko an die gewünschte Stelle. An der Änderung der Leiterbahnfarbe sehen Sie nun, dass Sie sich auf der/einer anderen Kupferebene bewegen. Wenn Sie die zukünftigen Dukos beeinflussen möchten, so drücken Sie [.] während Sie keine Leiterbahn verlegen. Jetzt stellt [o] die Optionen der zukünftigen Dukos ein. Rechts im Duko-Dialog können Sie sich oft verwendete Dukos fest einspeichern. Diese erscheinen dann auch unten in der Ebenen-Werkzeugleiste. Das ist sehr gut bei Multilayern einsetzbar.

WINDOW

Bildausschnitt festlegen oder Bild auffrischen.

In TARGET 3001!:

Drücken Sie die Taste [n] um das Bild aufzufrischen. Drücken Sie den Button WinFit.jpg, um das Bild formatfüllend darzustellen. Zoomen Sie mit dem Rollrad Ihrer Maus in 10% -Schritten in das Bild hinein und wieder heraus. Die Cursor-Position wird dabei zentral gestellt. Mit der rechten Maustaste können Sie jederzeit ein Zoom-Fenster festlegen. Wenn Sie das Zoom-Fenster jedoch rückwärts von rechts nach links aufziehen, wird das Blatt wieder komplett im Übersicht gezoomt.

WIRE

Wires (Linien) zeichnen.

In TARGET 3001!:

Signalbahnen zeichnen mit DrawSignal.jpg, Leiterbahnen zeichnen mit DrawTrack.jpg oder Linien mit Pen.jpg und Line.jpg. Mit [o] können Sie dann die Optionen der zukünftigen Segmente festlegen. Wollen Sie Segmente nachträglich ändern, markieren Sie diese und drücken Sie [ä]. Ein einzelnes Segment läßt sich auch mit einem Doppleklick editieren.


WRITE

Abspeichern einer Zeichnung oder Bibliothek.

In TARGET 3001!:

Wie in Windows üblich mit "Datei speichern" etc..